提示买卖的MACD主力清洗副图指标公式(附源码破译和源码)

提示买卖的MACD主力清洗副图指标公式(附源码破译和源码)

发布日期:2023-10-23 12:37    点击次数:77

编程思路破译

CXH1赋值:1日前的(最低价+开盘价+收盘价+最高价)/4

CXH2赋值:最低价-CXH1的绝对值的13日[1日权重]移动平均 / 最低价-CXH1和0的较大值的10日[1日权重]移动平均

CXH3赋值: CXH2的10日指数移动平均

CXH4赋值: 33日内最低价的最低值

CXH5赋值: 如果最低价<=CXH4,返回CXH3,否则返回0的3日指数移动平均

输出Z:0, 画白色

输出主力进场:如果CXH5>1日前的CXH5,返回CXH5,否则返回0,画红色, NODRAW

输出洗盘:如果CXH5<1日前的CXH5,返回CXH5,否则返回0, 画绿色, NODRAW

当满足条件CXH5<1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为3,0不为0则画空心柱., 画绿色

当满足条件CXH5>1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为3,0不为0则画空心柱., COLOR000055

当满足条件CXH5>1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLOR000077

当满足条件CXH5>1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为2.1,0不为0则画空心柱., COLOR000099

当满足条件CXH5>1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为1.5,0不为0则画空心柱., COLOR0000BB

当满足条件CXH5>1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为0.9,0不为0则画空心柱., COLOR0000DD

当满足条件CXH5>1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为0.3,0不为0则画空心柱., COLOR0000FF

当满足条件CXH5<1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为3,0不为0则画空心柱., COLOR005500

当满足条件CXH5<1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为2.6,0不为0则画空心柱., COLOR007700

当满足条件CXH5<1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为2.1,0不为0则画空心柱., COLOR009900

当满足条件CXH5<1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为1.5,0不为0则画空心柱., COLOR00BB00

当满足条件CXH5<1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为0.9,0不为0则画空心柱., COLOR00DD00

当满足条件CXH5<1日前的CXH5时,在0和CXH5位置之间画柱状线,宽度为0.3,0不为0则画空心柱., COLOR00FF00

CXH21赋值:最高价-CXH1的绝对值的13日[1日权重]移动平均 / 最高价-CXH1和0的较小值的10日[1日权重]移动平均

CXH31赋值:CXH21的10日指数移动平均

CXH41赋值:33日内最高价的最高值

CXH51赋值: 如果最高价>=CXH41,返回CXH31,否则返回0的3日指数移动平均

输出主力拉高:如果CXH51<1日前的CXH51,返回CXH51,否则返回0,画黄色,NODRAW

当满足条件CXH51<1日前的CXH51时,在0和CXH51位置之间画柱状线,宽度为3,0不为0则画空心柱., 画黄色

输出出货: 如果CXH51>1日前的CXH51,返回CXH51,否则返回0, 画青色, NODRAW

当满足条件CXH51>1日前的CXH51时,在0和CXH51位置之间画柱状线,宽度为3,0不为0则画空心柱., 画青色

CXH3赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100

CXH4赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100

CXH5赋值:(收盘价-收盘价的32日简单移动平均)/收盘价的32日简单移动平均*100

CXH6赋值:(CXH3+CXH4+CXH5)/3

CXH7赋值:CXH6的5日指数移动平均

输出指标: CXH3的5日指数移动平均的5日指数移动平均*3, COLORSTICK

CXH8赋值:如果CXH6<=-20,返回10,否则返回0

CXH9赋值:10日内CXH8的最高值

当满足条件CXH8=10时,在20和10位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR6666FF

CXHA赋值:如果CXH9ANDCROSS(收盘价的3日简单移动平均,收盘价的5日简单移动平均),返回20,否则返回0

输出K:CXH7的5日指数移动平均*2, , COLORFF00FF

输出D:K的5日指数移动平均, , 画白色

输出J:K*3-D*2, ,画黄色

CXHB赋值:收盘价位于收盘价的3日简单移动平均和收盘价的5日简单移动平均之间 AND J>10

换手赋值: 成交量(手)/当前流通股本(手)*100, , 画黄色

成交〖万手〗赋值:成交量(手)/10000, ,画白色

当满足条件CXH8=10ANDFILTER(CXH8=10,5)时,在-10位置书写文字,线宽为1,画黄色

当满足条件CXH8=10ANDFILTER(CXH8=10,5)时,在-1.6和-10位置之间画柱状线,宽度为5,0不为0则画空心柱.,画黄色

当满足条件CXHA=20时,在15位置书写文字,线宽为1,画白色

当满足条件(CXHA=20)时,在0和10位置之间画柱状线,宽度为5,0不为0则画空心柱.,画白色

CXHC赋值:(收盘价5%的之字转向>1日前的收盘价5%的之字转向) AND (1日前的收盘价5%的之字转向<=2日前的收盘价5%的之字转向) AND (2日前的收盘价5%的之字转向<=3日前的收盘价5%的之字转向)

CXHD赋值:(收盘价5%的之字转向<1日前的收盘价5%的之字转向) AND (1日前的收盘价5%的之字转向>=2日前的收盘价5%的之字转向) AND (2日前的收盘价5%的之字转向>=3日前的收盘价5%的之字转向)

当满足条件(CXHC=1)时,在(-14)和0位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR0000FF

当满足条件(CXHC=1)时,在(-14)位置书写文字,COLOR0000FF

当满足条件(CXHD=1)时,在14和0位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR00FF00

当满足条件(CXHD=1)时,在18位置书写文字,COLOR00FF00

CXHE赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20

CXHF赋值:100-3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均

CXH10赋值:100-3*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均

CXH11赋值:CXHF<1日前的CXH10 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价

当满足条件CXH11ANDCOUNT(CXH11,30)=1时,在15位置书写文字,线宽为1,COLORFF00FF

CXH12赋值:(最高价+最低价+收盘价)/3

CXH13赋值:(CXH12-CXH12的14日简单移动平均)/(0.015*CXH12的14日平均绝对偏差)

CXH14赋值:(CXH12-CXH12的70日简单移动平均)/(0.015*CXH12的70日平均绝对偏差)

CXH15赋值:如果CXH13>=150ANDCXH13<200ANDCXH14>=150ANDCXH14<200,返回10,否则返回0

CXH16赋值:如果CXH13<=-150ANDCXH13>-200ANDCXH14<=-150ANDCXH14>-200,返回-10,否则返回CXH15

CXH17赋值:(收盘价-收盘价的13日简单移动平均)/收盘价的13日简单移动平均*100

CXH18赋值:100-CXH17的绝对值

CXH19赋值:如果CXH18<90,返回CXH18,否则返回100

CXH1A赋值:如果CXHE>0,返回CXHE,否则返回0

CXH1B赋值:如果CXH14>=200ANDCXH13>=150,返回15,否则返回如果CXH14<=-200ANDCXH13<=-150,返回-15,否则返回CXH16+60

CXH1C赋值:CXH1A>48 AND CXH1B>60 AND CXH19<100

当满足条件CXH1CANDCOUNT(CXH1C,30)=1时,在15位置书写文字,线宽为1,COLORFFCC66

当满足条件CXH1CANDCOUNT(CXH1C,30)=1时,在0和10位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORFFCC66

程序源码

{主力清洗}cxh1:=REF((LOW + OPEN + CLOSE + HIGH) / 4, 1);cxh2:=SMA (ABS (LOW - cxh1), 13,1) / SMA (MAX(LOW-cxh1, 0),10,1);cxh3:= EMA (cxh2, 10);cxh4:= LLV (LOW, 33);cxh5:= EMA(IF(LOW <= cxh4, cxh3, 0), 3);Z:0, COLORWHITE;主力进场:IF (cxh5>REF (cxh5,1),cxh5,0),COLORRED, NODRAW;洗盘:IF (cxh5 < REF (cxh5,1), cxh5, 0), COLORGREEN, NODRAW;STICKLINE (cxh5 < REF (cxh5,1), 0, cxh5, 3, 0), COLORGREEN;STICKLINE (cxh5 > REF (cxh5,1), 0, cxh5, 3, 0), COLOR000055;STICKLINE (cxh5 > REF (cxh5, 1), 0, cxh5, 2.6, 0),COLOR000077;STICKLINE (cxh5 > REF (cxh5, 1), 0,cxh5, 2.1, 0), COLOR000099;STICKLINE (cxh5 > REF (cxh5,1),0,cxh5,1.5, 0), COLOR0000BB;STICKLINE (cxh5 > REF (cxh5,1),0, cxh5,0.9, 0), COLOR0000DD;STICKLINE (cxh5 > REF (cxh5,1),0, cxh5,0.3, 0), COLOR0000FF;STICKLINE (cxh5 < REF (cxh5, 1),0,cxh5,3,0), COLOR005500;STICKLINE (cxh5 < REF (cxh5,1),0, cxh5,2.6,0), COLOR007700;STICKLINE (cxh5 < REF (cxh5, 1),0,cxh5,2.1, 0), COLOR009900;STICKLINE (cxh5 < REF (cxh5,1),0 ,cxh5,1.5, 0), COLOR00BB00;STICKLINE (cxh5 < REF (cxh5,1),0 ,cxh5,0.9, 0), COLOR00DD00;STICKLINE (cxh5 < REF (cxh5,1),0, cxh5,0.3, 0), COLOR00FF00;cxh21:=SMA (ABS (HIGH - cxh1), 13, 1) / SMA (MIN (HIGH-cxh1, 0),10,1);

cxh31:=EMA (cxh21, 10);cxh41:=HHV (HIGH, 33);cxh51:= EMA(IF(HIGH >= cxh41, cxh31, 0), 3);主力拉高:IF(cxh51<REF (cxh51,1),cxh51,0),COLORYELLOW,NODRAW;STICKLINE (cxh51 < REF (cxh51, 1), 0, cxh51, 3,0), COLORYELLOW;出货: IF (cxh51 >REF (cxh51,1), cxh51, 0), COLORCYAN, NODRAW;STICKLINE (cxh51 > REF (cxh51, 1), 0, cxh51,3,0), COLORCYAN;

{买卖MACD}cxh3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;cxh4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;cxh5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;cxh6:=(cxh3+cxh4+cxh5)/3;cxh7:=EMA(cxh6,5);指标: EMA(EMA(cxh3,5),5)*3, COLORSTICK;cxh8:=IF(cxh6<=-20,10,0);cxh9:=HHV(cxh8,10);STICKLINE(cxh8=10,20,10,5,0),COLOR6666FF;cxhA:=IF(cxh9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);K:EMA(cxh7,5)*2, , COLORFF00FF;D:EMA(K,5), , COLORWHITE;J:K*3-D*2, ,COLORYELLOW;cxhB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;换手:= VOL/CAPITAL*100, , COLORYELLOW;成交〖万手〗:=VOL/10000, ,COLORWHITE;DRAWTEXT(cxh8=10 AND FILTER(cxh8=10,5),-10{15},'近底部'),LINETHICK1,COLORYELLOW;STICKLINE(cxh8=10 AND FILTER(cxh8=10,5),-1.6{20},-10,5,0),COLORYELLOW;DRAWTEXT(cxhA=20,15,'底部'),LINETHICK1,COLORWHITE;STICKLINE((cxhA=20),0,10,5,0),COLORWHITE;cxhC:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG (3,5),2)<=REF(ZIG(3,5),3));cxhD:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG (3,5),2)>=REF(ZIG(3,5),3));STICKLINE((cxhC=1),(-14),0,4,0),COLOR0000FF;DRAWTEXT((cxhC=1),(-14),'买'),COLOR0000FF;STICKLINE((cxhD=1),14,0,4,0),COLOR00FF00;DRAWTEXT((cxhD=1),18,'卖'),COLOR00FF00;cxhE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;cxhF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA ((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);cxh10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA ((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);cxh11:=cxhF<REF(cxh10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);DRAWTEXT(cxh11 AND COUNT(cxh11,30)=1,15,'大资金活动'),LINETHICK1,COLORFF00FF;{STICKLINE(cxh11 AND COUNT(cxh11,30)=1,1,10,5,0),COLORFF00FF;}cxh12:=(HIGH+LOW+CLOSE)/3;cxh13:=(cxh12-MA(cxh12,14))/(0.015*AVEDEV(cxh12,14));cxh14:=(cxh12-MA(cxh12,70))/(0.015*AVEDEV(cxh12,70));cxh15:=IF(cxh13>=150 AND cxh13<200 AND cxh14>=150 AND cxh14<200,10,0);cxh16:=IF(cxh13<=-150 AND cxh13>-200 AND cxh14<=-150 AND cxh14>-200,-10,cxh15);cxh17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;cxh18:=100-ABS(cxh17);cxh19:=IF(cxh18<90,cxh18,100);cxh1A:=IF(cxhE>0,cxhE,0);cxh1B:=IF(cxh14>=200 AND cxh13>=150,15,IF(cxh14<=-200 AND cxh13<=-150,-15,cxh16))+60;cxh1C:=cxh1A>48 AND cxh1B>60 AND cxh19<100;DRAWTEXT(cxh1C AND COUNT(cxh1C,30)=1,15,'大笔出货'),LINETHICK1,COLORFFCC66;STICKLINE(cxh1C AND COUNT(cxh1C,30)=1,0,10,5,0),COLORFFCC66;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。

友情链接:

Powered by 股指期货配资平台_黄金期货配资开户_国家允许配资官网 @2013-2022 RSS地图 HTML地图

Copyright 站群系统 © 2014-2024 联华证券 版权所有