一阳乾坤线系统指标公式(附源码破译和源码)

一阳乾坤线系统指标公式(附源码破译和源码)

发布日期:2023-10-23 12:21    点击次数:166

编程思路破译

输出EXP1:收盘价的M1日指数移动平均,线宽为2

输出EXP2:收盘价的M2日指数移动平均,线宽为3

豆豆赋值:收盘价

A1赋值:10日前的豆豆=2*10+1日内豆豆的最高值

B1赋值:A1的10日过滤

C1赋值:若B1则将最近10+1周期置为1

HD赋值:C1的10日过滤

A2赋值:10日前的豆豆=2*10+1日内豆豆的最低值

B2赋值:A2的10日过滤

C2赋值:若B2则将最近10+1周期置为1

LD赋值:C2的10日过滤

A赋值:上次HD距今天数日前的收盘价

B赋值:上次LD距今天数日前的最低价

T1赋值:上次HD距今天数<上次LD距今天数 AND 取反

T2赋值:上次HD距今天数>上次LD距今天数 AND 取反

输出压力:如果T1,返回A,否则返回A,画红色,POINTDOT,线宽为4

输出支撑:如果T2,返回B,否则返回B,画黄色,POINTDOT,线宽为4

二分之一位赋值:如果收盘价>OANDC>1日前的收盘价,返回最低价+(最高价-最低价)/2,否则返回最低价+(最高价-最低价)/2

当满足条件到最后交易的周期时,在二分之一位和二分之一位位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色

当满足条件到最后交易的周期=2时,在二分之一位和二分之一位位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色

输出当前二分之一位:最低价+(最高价-最低价)/2,NODRAW

程序源码

EXP1:EXPMA(CLOSE,M1),LINETHICK2;EXP2:EXPMA(CLOSE,M2),LINETHICK3;豆豆:=C;A1:=REF(豆豆,10)=HHV(豆豆,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);A2:=REF(豆豆,10)=LLV(豆豆,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);A:=REF(C,BARSLAST(HD)); B:=REF(L,BARSLAST(LD));T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);压力:IF(T1,A,A),COLORRED,POINTDOT,LINETHICK4;支撑:IF(T2,B,B),COLORYELLOW,POINTDOT,LINETHICK4;二分之一位:=IF(C>O AND C>REF(C,1),L+(H-L)/2,L+(H-L)/2);STICKLINE(CURRBARSCOUNT,二分之一位,二分之一位,3,1),COLORYELLOW;STICKLINE(CURRBARSCOUNT=2,二分之一位,二分之一位,3,1),COLORYELLOW;当前二分之一位:L+(H-L)/2,NODRAW;

注:

       馆内各种公式为学习编程而保存,实战使用前一定要看其中是否有未来函数并自己亲自测试成功率,决不能依据公式名称的描述和形容去投资,据此入市造成投资损失由投资者自己承担。

       发文不易,如获益,欢迎赞赏,赞赏必复!

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。

友情链接:

Powered by 股指期货配资平台_黄金期货配资开户_国家允许配资官网 @2013-2022 RSS地图 HTML地图

Copyright 站群系统 © 2014-2024 联华证券 版权所有